API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickObjects Method (PickerPickObjectsEnum, String)

Queries the user to pick model objects from the model with the given prompt.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public ModelObjectEnumerator PickObjects(
	PickerPickObjectsEnum Enum,
	string Prompt
)

Parameters

Enum
Type: Tekla.Structures.Model.UIPickerPickObjectsEnum
Indicates the type and amount of objects to pick.
Prompt
Type: SystemString
The string to display as user guidance.

Return Value

Type: ModelObjectEnumerator
An enumerator of model object instances.
See Also