API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickFace Method (String)

Queries the user to pick a face from the model with the given prompt.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public PickInput PickFace(
	string Prompt
)

Parameters

Prompt
Type: SystemString
The string to display as user guidance.

Return Value

Type: PickInput
A list of the vertices of the face and the object the user picked as one PickInput instance.
See Also