API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectSelectorGetSelectedObjects Method

Returns an enumerator of all the selected model objects in the model view.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public ModelObjectEnumerator GetSelectedObjects()

Return Value

Type: ModelObjectEnumerator
A model object enumerator of all the selected model objects.
See Also