API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GraphicsDrawerDrawPolyLine Method

Draw a temporary polyline into all open Tekla Structures views.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public int DrawPolyLine(
	GraphicPolyLine GraphicPolyLine
)

Parameters

GraphicPolyLine
Type: Tekla.Structures.Model.UIGraphicPolyLine
The polyline to draw.

Return Value

Type: Int32
The identifier of the temporary graphic. You can delete the graphic with RemoveTemporaryGraphicsObject.
See Also