API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GraphicsDrawerDrawMeshLines Method

Draws the mesh lines as temporary graphics in the currently active Tekla Structures rendered view.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public bool DrawMeshLines(
	Mesh Mesh,
	Color Color
)

Parameters

Mesh
Type: Tekla.Structures.Model.UIMesh
The mesh to draw.
Color
Type: Tekla.Structures.Model.UIColor
The color of the mesh lines. The transparency value of the color is ignored.

Return Value

Type: Boolean
True on success.
See Also