API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelHistoryGetModifications Method (String, IEnumerableModelObjectModelObjectEnum, ModificationStamp)

Lookup modifications since previous call of TakeModifications() without resetting the modstamp, with object type filtering

Namespace:  Tekla.Structures.Model.History
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public static ModificationInfo GetModifications(
	string Name,
	IEnumerable<ModelObjectModelObjectEnum> ObjectTypes,
	ModificationStamp PrevStamp = null
)

Parameters

Name
Type: SystemString
Name of reference which is used for collecting modifications and which is updated. Intended use is to assign an unique name for each client application which needs to be informed of the model updates. Maximum length is 79 characters.
ObjectTypes
Type: System.Collections.GenericIEnumerableModelObjectModelObjectEnum
Types of object to select. Empty or null selects all types.
PrevStamp (Optional)
Type: Tekla.Structures.Model.HistoryModificationStamp
When specified, default value of reference if is it not found

Return Value

Type: ModificationInfo
All modifications which happened since the last call
Remarks
Same as GetModifications(String, ModificationStamp), but returns only the types listed in ObjectTypes.
See Also