API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelHistoryGetDeletedObjectsWithType Method

Note: This API is now obsolete.

Gets based on type a list of the objects that have been deleted after the modification stamp.

Namespace:  Tekla.Structures.Model.History
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
[ObsoleteAttribute("Use TakeModifications() instead.")]
public static ModelObjectEnumerator GetDeletedObjectsWithType(
	ModificationStamp ModStamp,
	ModelObjectModelObjectEnum Enum
)

Parameters

ModStamp
Type: Tekla.Structures.Model.HistoryModificationStamp
The modification stamp.
Enum
Type: Tekla.Structures.ModelModelObjectModelObjectEnum
The type of the objects to return.

Return Value

Type: ModelObjectEnumerator
A list of the objects that have been deleted after the given modification stamp.
See Also