API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UndefinedCurveDirectionException Class

The UndefinedCurveDirectionException class represents an error when, cannot make inward/outward curve check.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public class UndefinedCurveDirectionException : ConnectiveGeometryException

The UndefinedCurveDirectionException type exposes the following members.

Constructors
  NameDescription
Public methodUndefinedCurveDirectionException
Initializes a new instance of the UndefinedCurveDirectionException class with "Cannot make inward/outward curve check" error message.
Top
Fields
  NameDescription
Top
See Also