API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SpiralBeamErrorStatus Enumeration

Define possible statuses for geometry creation/modification commands.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public enum ErrorStatus
Members
  Member nameValueDescription
DataMissing0 Status when some part data is missing.
DefinitionPointsTooClose1 Status when definition points are too close.
DefinitionPointsCannotBeAligned2 Status when definition points are on line with sweep direction.
ZeroTotalRiseWithMore360Degrees3 Status when total rise is zero and rotation angle more than 360 degrees.
See Also