API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SpiralBeamModify Method

Modifies the spiral beam object values in the database.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public override bool Modify()

Return Value

Type: Boolean
True if success
Exceptions
ExceptionCondition
SpiralBeamDataExceptionThrows exception if input data is invalid.
See Also