API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SolidSolidCreationTypeEnum Enumeration

The creation type of the solid.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public enum SolidCreationTypeEnum
Members
  Member nameValueDescription
RAW0 The solid is created without any boolean operations.
FITTED1 The solid is created with fittings.
NORMAL2 The solid is created including all cutting and fitting operations.
HIGH_ACCURACY3 The solid is created as normal with an exact profile cross section.
PLANECUTTED4 The solid is created with fittings and cut planes.
NORMAL_WITHOUT_EDGECHAMFERS5 The solid is created including all cutting and fitting operations without edge chamfers.
NORMAL_WITHOUT_WELDPREPS6 The solid is created including all cutting and fitting operations without weld prepping.
See Also