API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SolidGetAllIntersectionPoints Method

Used to get all the intersection points between the solid and a plane. Does not arrange the points into polygons, thus a lot faster.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public IEnumerator GetAllIntersectionPoints(
	Point point1,
	Point point2,
	Point point3
)

Parameters

point1
Type: Tekla.Structures.Geometry3dPoint
1st of the 3 points defining a plane
point2
Type: Tekla.Structures.Geometry3dPoint
2nd of the 3 points defining a plane
point3
Type: Tekla.Structures.Geometry3dPoint
3rd of the 3 points defining a plane

Return Value

Type: IEnumerator
An IEnumerator containing the intersection points of type the Point
See Also