API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReferenceModel Constructor (String, Point, Double)

Initializes a new instance of the ReferenceModel class. Creates a new reference model instance using the given filename, position and scale.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public ReferenceModel(
	string filename,
	Point position,
	double scale
)

Parameters

filename
Type: SystemString
The filename to be used.
position
Type: Tekla.Structures.Geometry3dPoint
The position to be used.
scale
Type: SystemDouble
The scale to be used.
See Also