API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProjectInfoGetBasePointByGuid Method

Gets a base point by given guid.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public static BasePoint GetBasePointByGuid(
	Guid guid
)

Parameters

guid
Type: SystemGuid
The guid of the base point.

Return Value

Type: BasePoint
If found, the base point, otherwise empty base point.
See Also