API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PartGetSolid Method (SolidSolidCreationTypeEnum)

Returns the solid of the part.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public Solid GetSolid(
	SolidSolidCreationTypeEnum solidCreationType
)

Parameters

solidCreationType
Type: Tekla.Structures.ModelSolidSolidCreationTypeEnum
The type to be used in solid creation.

Return Value

Type: Solid
The solid of the part.
See Also