API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectGetDoubleReportProperties Method

Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public bool GetDoubleReportProperties(
	ArrayList names,
	ref Hashtable values
)

Parameters

names
Type: System.CollectionsArrayList
An array list containing the names of the properties.
values
Type: System.CollectionsHashtable
The return value, a hash table that contains all the values that were retrieved successfully.

Return Value

Type: Boolean
True if at least one single property was retrieved successfully.
See Also