API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Material Class

The Material class represents a single material that parts can be made of.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelMaterial

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public sealed class Material

The Material type exposes the following members.

Constructors
  NameDescription
Public methodMaterial
Instantiates an empty material instance.
Top
Properties
  NameDescription
Public propertyMaterialString
Identifies the material in a string format.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Beam beam = new Beam(new Point(5000, 7000, 0), new Point(6000, 7000, 0));
           beam.Material.MaterialString = "K40-1";
           beam.Profile.ProfileString = "250*250";
           beam.Finish = "PAINT";

           bool result = false;
           result = beam.Insert();
       }
}
See Also