API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ControlPlane Constructor (Plane, Boolean)

Creates a new control plane instance taking the plane and magnetism as input.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public ControlPlane(
	Plane P,
	bool IsMagnetic
)

Parameters

P
Type: Tekla.Structures.ModelPlane
The plane to be used.
IsMagnetic
Type: SystemBoolean
Determines whether the plane is magnetic or not.
See Also