API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ConnectionSetPrimaryObject Method

Sets the primary object of the connection.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public bool SetPrimaryObject(
	ModelObject M
)

Parameters

M
Type: Tekla.Structures.ModelModelObject
The primary object.

Return Value

Type: Boolean
True on success.
See Also