API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ClashCheckHandlerGetIntersectionBoundingBoxes Method

Get a list of bounding boxes (AABB) of the clashing volumes of two objects.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public ArrayList GetIntersectionBoundingBoxes(
	Identifier ID1,
	Identifier ID2
)

Parameters

ID1
Type: Tekla.StructuresIdentifier
The identifier of the first object.
ID2
Type: Tekla.StructuresIdentifier
The identifier of the second object.

Return Value

Type: ArrayList
A list of bounding boxes of the clashing volumes.
See Also