API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ChangeData Class

The ChangeData class presents information about the detected change of the modelobject in the model. It is instantiated inside the connected method.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelChangeData

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public class ChangeData

The ChangeData type exposes the following members.

Properties
  NameDescription
Public propertyObject
Gets the changed object.
Public propertyType
Gets the changed object.
Top
See Also