API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Chamfer Constructor (Double, Double, ChamferChamferTypeEnum)

Instantiates a chamfer with the given values.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public Chamfer(
	double X,
	double Y,
	ChamferChamferTypeEnum Type
)

Parameters

X
Type: SystemDouble
The X value of the chamfer.
Y
Type: SystemDouble
The Y value of the chamfer.
Type
Type: Tekla.Structures.ModelChamferChamferTypeEnum
The basic shape type of the chamfer.
See Also