API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Brep Constructor (Point, Point)

Initializes a new instance of the Brep class with the given start and end points.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public Brep(
	Point startPoint,
	Point endPoint
)

Parameters

startPoint
Type: Tekla.Structures.Geometry3dPoint
The start point for the brep.
endPoint
Type: Tekla.Structures.Geometry3dPoint
The end point for the brep.
See Also