API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BoltXYListGetBoltDistX Method

Returns the X distance defined by the argument.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public double GetBoltDistX(
	int Index
)

Parameters

Index
Type: SystemInt32
The index to the distance list.

Return Value

Type: Double
The distance defined by the argument.
See Also