API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BoltArraySetBoltDistX Method

Sets the X distance at the index defined by the argument.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public bool SetBoltDistX(
	int Index,
	double DistX
)

Parameters

Index
Type: SystemInt32
The index to the distance list.
DistX
Type: SystemDouble
The X distance to be used.

Return Value

Type: Boolean
True if the distance was modified. False if the index is out of range.
See Also