API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BentPlateGeometrySolverModifyRadius Method

Modify the radius of a cylindrical section.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public ConnectiveGeometry ModifyRadius(
	ConnectiveGeometry geometry,
	GeometrySection cylindricalSection,
	double radius
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
Reference geometry to modify which contains cylindricalSection.
cylindricalSection
Type: Tekla.Structures.ModelGeometrySection
The cylindrical geometry section to modify.
radius
Type: SystemDouble
The new radius for the cylindrical section.

Return Value

Type: ConnectiveGeometry
Modified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
ExceptionCondition
ConnectiveGeometryExceptionThrown if could not modify radius.
See Also