API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BaseWeldWeldProcessTypeEnum Enumeration

The weld process type.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public enum WeldProcessTypeEnum
Members
  Member nameValueDescription
WELD_PROCESS_NONE0 No process type.
WELD_PROCESS_SMAW1 The shielded metal arc (SMAW) process type.
WELD_PROCESS_SAW2 The submerged arc (SAW) process type.
WELD_PROCESS_GMAW3 The gas metal arc (GMAW) process type.
WELD_PROCESS_FCAW4 The flux cored arc (FCAW) process type.
WELD_PROCESS_ESW5 The electroslag (ESW) process type.
WELD_PROCESS_EGW6 The electrogas (EGW) process type.
See Also