API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BasePointConvertToBasePoint Method (BasePoint, Point)

Converts the given local point to given base point.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public static Point ConvertToBasePoint(
	BasePoint basePoint,
	Point point
)

Parameters

basePoint
Type: Tekla.Structures.ModelBasePoint
The base point, to which the point is converted to.
point
Type: Tekla.Structures.Geometry3dPoint
The point to be converted.

Return Value

Type: Point
On success, the converted value. Otherwise the original value.
See Also