API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BasePoint Constructor (Int32, Guid, String, String, String, String, Double, Double, Double, Double, Double, Double, Double, Double, Double, Boolean, Boolean)

Initializes a new instance of the BasePoint class.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public BasePoint(
	int id,
	Guid guid,
	string initialGuid,
	string name,
	string description,
	string coordinateSystem,
	double northSouth,
	double eastWest,
	double elevation,
	double latitude,
	double longitude,
	double locationInModelX,
	double locationInModelY,
	double locationInModelZ,
	double angleToNorth,
	bool isProjectBasePoint,
	bool isCurrentBasePoint
)

Parameters

id
Type: SystemInt32
The id.
guid
Type: SystemGuid
The guid.
initialGuid
Type: SystemString
The initial guid.
name
Type: SystemString
The name.
description
Type: SystemString
The description.
coordinateSystem
Type: SystemString
The coordinate system.
northSouth
Type: SystemDouble
The north-south.
eastWest
Type: SystemDouble
The east-west.
elevation
Type: SystemDouble
The elevation.
latitude
Type: SystemDouble
The latitude.
longitude
Type: SystemDouble
The longitude.
locationInModelX
Type: SystemDouble
The location in model x.
locationInModelY
Type: SystemDouble
The location in model y.
locationInModelZ
Type: SystemDouble
The location in model z.
angleToNorth
Type: SystemDouble
The angle to north in radians.
isProjectBasePoint
Type: SystemBoolean
Boolean indicating if this base point is the project base point.
isCurrentBasePoint
Type: SystemBoolean
Boolean indicating if this base point is the current base point.
See Also