API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

VectorMultiply Operator (Vector, Double)

Calculates the multiplication of the given vector with the given scalar.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public static Vector operator *(
	Vector Vector,
	double Multiplier
)

Parameters

Vector
Type: Tekla.Structures.Geometry3dVector
The vector to be multiplied.
Multiplier
Type: SystemDouble
The scalar to multiply the vector with.

Return Value

Type: Vector
The new vector that is the multiplication of the vector and the scalar.
See Also