API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

VectorNormalize Method (Double)

Normalizes the vector using the given length.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public double Normalize(
	double NewLength
)

Parameters

NewLength
Type: SystemDouble
The length to be used.

Return Value

Type: Double
The normalized vector's length.
See Also