API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProjectionPointToPlane Method

Returns a new point which is a projection of the given point onto the given plane.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public static Point PointToPlane(
	Point Point,
	GeometricPlane Plane
)

Parameters

Point
Type: Tekla.Structures.Geometry3dPoint
The point to be used.
Plane
Type: Tekla.Structures.Geometry3dGeometricPlane
The plane to be used.

Return Value

Type: Point
The new projection point.
See Also