API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PointAddition Operator

Returns the sum of the given two points.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public static Point operator +(
	Point p1,
	Point p2
)

Parameters

p1
Type: Tekla.Structures.Geometry3dPoint
The first point to be used.
p2
Type: Tekla.Structures.Geometry3dPoint
The second point to be used.

Return Value

Type: Point
The sum of the given two points.
See Also