API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PointTranslate Method

Translates the point using the given vector.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public virtual void Translate(
	double X,
	double Y,
	double Z
)

Parameters

X
Type: SystemDouble
The X-translation to be used.
Y
Type: SystemDouble
The Y-translation to be used.
Z
Type: SystemDouble
The Z-translation to be used.
See Also