API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ParallelLineToLine Method (Line, Line)

Returns true if the given lines are parallel.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public static bool LineToLine(
	Line Line1,
	Line Line2
)

Parameters

Line1
Type: Tekla.Structures.Geometry3dLine
The first line to be used.
Line2
Type: Tekla.Structures.Geometry3dLine
The second line to be used.

Return Value

Type: Boolean
True if the given lines are parallel.
See Also