API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ParallelLineSegmentToPlane Method (LineSegment, GeometricPlane)

Returns true if the given line segment and plane are parallel.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public static bool LineSegmentToPlane(
	LineSegment LineSegment,
	GeometricPlane Plane
)

Parameters

LineSegment
Type: Tekla.Structures.Geometry3dLineSegment
The line segment to be used.
Plane
Type: Tekla.Structures.Geometry3dGeometricPlane
The plane to be used.

Return Value

Type: Boolean
True if the given line segment and plane are parallel.
See Also