API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBSetExtent Method (Double, Double, Double)

Sets the extents to the OBB.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public void SetExtent(
	double extent0,
	double extent1,
	double extent2
)

Parameters

extent0
Type: SystemDouble
The extent (half-length) of the side parallel to axis one.
extent1
Type: SystemDouble
The extent (half-length) of the side parallel to axis two.
extent2
Type: SystemDouble
The extent (half-length) of the side parallel to axis three.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when setting the extent fails.
See Also