API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBSetAxis Method (Vector, Vector, Vector)

Sets the Axis to the OBB.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public void SetAxis(
	Vector axis0,
	Vector axis1,
	Vector axis2
)

Parameters

axis0
Type: Tekla.Structures.Geometry3dVector
Unit-length vector parallel to one axis of the OBB.
axis1
Type: Tekla.Structures.Geometry3dVector
Unit-length vector parallel to the second axis of the OBB.
axis2
Type: Tekla.Structures.Geometry3dVector
Unit-length vector parallel to the third axis of the OBB.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when setting the axis fails.
See Also