API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBIntersects Method (OBB)

Tests if current OBB intersects with the given OBB

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public bool Intersects(
	OBB obb
)

Parameters

obb
Type: Tekla.Structures.Geometry3dOBB
OBB to test against

Return Value

Type: Boolean
True if the OBBs intersect, otherwise false
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the obb parameter.
See Also