API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBIntersects Method (Line)

Tests if current OBB intersects with the given Line

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public bool Intersects(
	Line line
)

Parameters

line
Type: Tekla.Structures.Geometry3dLine
Line to test against

Return Value

Type: Boolean
True if the OBB intersects with the given Line, otherwise false
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the line parameter.
See Also