![]() | OBBIntersectionWith Method (LineSegment) |
Creates an intersection between the OBB and the given LineSegment.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611

Parameters
- lineSegment
- Type: Tekla.Structures.Geometry3dLineSegment
LineSegment to calculate against
Return Value
Type: LineSegmentIntersection as LineSegment or null if no intersection was found.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when null is assigned to the lineSegment parameter. |