API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBClosestPointTo Method (Line)

Calculates the closest point in OBB to given Line.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public Point ClosestPointTo(
	Line line
)

Parameters

line
Type: Tekla.Structures.Geometry3dLine
Line to calculate against.

Return Value

Type: Point
Closest point in OBB to given Line.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the line parameter.
See Also