API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBCenter Property

Gets or sets the center point of the box.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public Point Center { get; set; }

Property Value

Type: Point
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the property.
ArgumentExceptionThrown when setting the value fails.
See Also