API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Line Constructor (Point, Vector)

Instantiates a line defined by the given point and direction vector.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public Line(
	Point Point,
	Vector Direction
)

Parameters

Point
Type: Tekla.Structures.Geometry3dPoint
A point that will be on the line.
Direction
Type: Tekla.Structures.Geometry3dVector
The direction of the line.
See Also