API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IntersectionLineToLine Method

Returns a new line segment which is the shortest path between the given lines or null if the lines are parallel. If the resulting line segment has a length of 0.0, the given lines actually intersect in 3d space.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public static LineSegment LineToLine(
	Line line1,
	Line line2
)

Parameters

line1
Type: Tekla.Structures.Geometry3dLine
The first line to be used.
line2
Type: Tekla.Structures.Geometry3dLine
The second line to be used.

Return Value

Type: LineSegment
The shortest line segment between the given lines or null if the lines are parallel.
See Also