API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AABBAddition Operator (Point, AABB)

Adds the given point to the given axis-aligned 3d bounding box.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public static AABB operator +(
	Point Point,
	AABB AABB
)

Parameters

Point
Type: Tekla.Structures.Geometry3dPoint
The point to be added.
AABB
Type: Tekla.Structures.Geometry3dAABB
The axis-aligned 3d bounding box to add to.

Return Value

Type: AABB
The new axis-aligned 3d bounding box which includes the given axis-aligned 3d bounding box and the given point.
See Also