API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AABBAddition Operator (AABB, AABB)

Combines (adds) the given two axis-aligned 3d bounding boxes.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public static AABB operator +(
	AABB AABB1,
	AABB AABB2
)

Parameters

AABB1
Type: Tekla.Structures.Geometry3dAABB
The first axis-aligned 3d bounding box to combine.
AABB2
Type: Tekla.Structures.Geometry3dAABB
The second axis-aligned 3d bounding box to combine.

Return Value

Type: AABB
The new combined axis-aligned 3d bounding box.
See Also