API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BinaryFilterExpressionCollectionIsLast Method

Determines whether an element is the last item of the collection.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public bool IsLast(
	BinaryFilterExpressionItem BinaryFilterExpressionItem
)

Parameters

BinaryFilterExpressionItem
Type: Tekla.Structures.FilteringBinaryFilterExpressionItem
The element to evaluate. This value cannot be null.

Return Value

Type: Boolean
True if the element is the last item.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the supplied item is null.
See Also