API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickPoints Method (Int32, StringList)

Requests N picks of points from the user. Returns the picked points in the view coordinates and the view in which the pick occurred.

Namespace:  Tekla.Structures.Drawing.UI
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public Tuple<PointList, ViewBase> PickPoints(
	int numberOfPicks,
	StringList prompts
)

Parameters

numberOfPicks
Type: SystemInt32
The number of requested picks.
prompts
Type: Tekla.Structures.DrawingStringList
The prompts shown in the status bar before the picks. See the class remarks for more information about prompts.

Return Value

Type: TuplePointList, ViewBase

[Missing <returns> documentation for "M:Tekla.Structures.Drawing.UI.Picker.PickPoints(System.Int32,Tekla.Structures.Drawing.StringList)"]

Exceptions
ExceptionCondition
InvalidPluginPickerInputException Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined.
PickerInterruptedException Thrown when the user interrupts the picker before anything has been picked.
See Also