API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickPoint Method (String, Point, ViewBase)

Requests the user to pick one point.

Namespace:  Tekla.Structures.Drawing.UI
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public void PickPoint(
	string prompt,
	out Point pickedPoint,
	out ViewBase pickedView
)

Parameters

prompt
Type: SystemString
The prompt shown in the status bar. See the class remarks for more information about prompts.
pickedPoint
Type: Tekla.Structures.Geometry3dPoint
The picked point in the view coordinates.
pickedView
Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.
Exceptions
ExceptionCondition
InvalidPluginPickerInputException Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined.
PickerInterruptedException Thrown when the user interrupts the picker before anything has been picked.
See Also